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Note on these mounting and operating instructions

These mounting and operating instructions assist you in mounting and operating the device 
safely. The instructions are binding for handling SAMSON devices. The images shown in 
these instructions are for illustration purposes only. The actual product may vary.

 Î For the safe and proper use of these instructions, read them carefully and keep them for 
later reference.

 Î If you have any questions about these instructions, contact SAMSON‘s After-sales Service 
(aftersalesservice@samsongroup.com).

The mounting and operating instructions for the devices are included 
in the scope of delivery. The latest documentation is available on our 
website at www.samsongroup.com > Service & Support > Downloads > 
Documentation.

 Definition of signal words 

Hazardous situations which, if not avoided, 
will result in death or serious injury

Hazardous situations which, if not avoided, 
could result in death or serious injury

Property damage message or malfunction

Additional information

Recommended action

DANGER!

WARNING!

NOTICE!

Note

Tip
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General

1 General
The	TROVIS-VIEW	4	software	allows	users	to	configure	and	parameterize	various	SAMSON	
devices over a common user interface. It consists of the operator interface, communication 
server	(SCS)	and	the	device-specific	module.	Device-specific	modules	are	available	for	the	
SAMSON products listed below:
Electropneumatic positioners (4-20 mA)
 − TROVIS 3730-1 (V 3.00 and higher)
 − Type 3730-2 (V 1.10 and higher)
 − TROVIS 3730-3 with HART® communication (V 2.00 and higher)
 − Type 3730-3 with HART® communication (V 1.10 and higher)
 − Type/TROVIS SAFE 3730-6 with HART® communication and pressure sensors  

(V 1.00 and higher)
 − Type/TROVIS SAFE 3731-3 with HART® communication (V 1.30 and higher)

Electropneumatic positioners (with bus communication)
 − Type 3730-4 with PROFIBUS-PA communication (R 1.43/K 1.00 and higher)
 − Type	3730-5	with	FOUNDATION™	fieldbus	communication	(R	1.40/K	1.20	and	higher)
 − Type	3731-5	with	FOUNDATION™	fieldbus	communication	(R	1.45/K	1.25	and	higher)

TROVIS 379x Positioners
 − TROVIS/TROVIS SAFE 3793 with HART® communication (V 1.00 and higher)

Electronic limit switches
 − Type 3738-20 (V 1.00 and higher)
 − Type 3738-50 (A 1.00/K 1.00 and higher)

Transmitters
 − Media 6/Type 5006 (V 2.00 and higher)
 − Media 7/Type 5007-1 (V 1.00 and higher)
 − SAM Connect Gateway/Type 5007-2 (V 1.00 and higher)

TROVIS 5500 Automation System
 − TROVIS 5573 (V 1.80 and higher)
 − TROVIS 5575 (V 1.50 and higher)
 − TROVIS 5576 (V 1.50 and higher)
 − TROVIS 5578 (V 2.20 and higher)
 − TROVIS 5578-E (V 2.50 and higher)
 − TROVIS 5579 (V 1.50 and higher)

TROVIS 5600 Automation System
 − TROVIS 5610 (V 1.06 and higher)
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Electric actuators
 − Type 3374 (V 2.00 and higher)
 − Type 3375 (V 3.00 and higher) · Discontinued
 − Type 5824/5825 (V 1.03 and higher)
 − Type 5827 (V 2.00 and higher)
 − Type 5857 (V 1.02 and higher)

Electric actuators with process controllers
 − TROVIS 5724-3 (V 1.00 and higher)
 − TROVIS 5724-8 (V 1.xx and higher (Bluetooth®) and V 2.xx (RS-485))
 − TROVIS 5725-3 (V 1.00 and higher)
 − TROVIS 5725-8 (V 1.xx and higher (Bluetooth®) and V 2.xx (RS-485))
 − TROVIS 5757-3 (V 1.00 and higher)

Industrial controllers
 − TROVIS 6493 (V 2.03 and higher)
 − TROVIS 6495-2 (V 1.10 and higher)

1.1 System requirements
 − Serial RS-232 interface or USB interface (with USB to RS-232 adapter or USB 
Converter 3	for	TROVIS	5500	Automation	System)	and	suitable	hardware	depending	on	
the SAMSON device used

 − Operating system*: Windows® 10 or Windows® 11 · Administrator rights are required to 
install the software
 * TROVIS-VIEW 4.68 and lower also ran under the 32-bit version of Windows® 10. 
Installation was also possible under Windows® 7 SP1 with Microsoft® .NET Framework 
4.7.1	(client	profile)	for	TROVIS-VIEW	4.68	or	lower 
Installation also possible under Windows® XP SP3 with Microsoft® .NET Framework 
4.0	(client	profile)	for	TROVIS-VIEW	4.39	or	lower

 − For communication over Bluetooth* (e.g. TROVIS 5724-8): Internal or external Bluetooth 
adapter (Bluetooth version 2.1 and higher)
* Not all device types can communicate over Bluetooth. More details are included in the mounting 

and operating instructions of the device. Bluetooth communication is not possible if these instruc-
tions do not contain any information on this topic.
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 − Microsoft® .NET Framework 4.6 (for TROVIS-VIEW 4.40 to 4.47) 
Microsoft® .NET Framework 4.6.1 (for TROVIS-VIEW 4.50 to 4.61) 
Microsoft® .NET Framework 4.7.1 (for TROVIS-VIEW 4.62 to 4.68) 
Microsoft®	.NET	Framework	≥2	(for	TROVIS-VIEW	4.70	and	higher)

 − PDF reader

1.2 Installing the software

Note concerning the installation from a downloaded ZIP file:
Download and unzip the ZIP file on your system before starting the installation. You can 
download the file free of charge from our website at www.samsongroup.com > Service & 
Support > Downloads > TROVIS-VIEW.

Note concerning the installation from a CD-ROM:
Once inserted, the CD-ROM starts the installation program automatically, depending on the 
configuration of the operating system. You do not need to run the setup.exe.

 Î If necessary, start the installation from the setup.exe.
 Î Follow the on-screen prompts and instructions of the installation program.

Note

Note
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1.3 Starting the program
Once it has been installed, TROVIS-VIEW can be started from the Windows® start menu.

 Î Open Windows® start menu.
 Î Open SAMSON TROVIS-VIEW 4.
A dialog box opens listing all in-
stalled device module versions at the 
program start.
Devices which have already been 
connected with the PC before open-
ing TROVIS-VIEW are displayed in 
the	[Automatic	detection]	field	in-
cluding details on the USB/COM 
port and device module version.

 Î Select which language is to be used 
for the device module.

 Î Select the device module and con-
firm	with	[OK].

You can assign frequently used device modules to open directly from the 
Windows® start menu.

Alternatively, you can create a shortcut on the desktop for them.

The individual device modules in TROVIS-VIEW 4.39 or lower can only opened directly from 
the Windows® start menu.

1.4 Accessories for data transmission
The accessories listed below are available to transfer data between the SAMSON device and 
the computer. Only accessories marked with “(Ex)” are suitable for use in hazardous areas. 
The accessories used depend on the device:

Note
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Connecting cable RJ-12/D-Sub 1)Order no. 1400-7699

Memory pen-64 (1170-3163) Order no. 1400-9753

Modular adapter 1) Order no. 1400-7698
Hardware package (memory pen-
64, modular adapter, conn. cable)

Order no. 1400-9998

Infrared adapter RS-232 1) Order no. 8864-0900

Bracket for infrared adapter Order no. 1400-9769
USB cable (mini-B, USB type A) 5) Order no. 8801-7301

Isolated USB interface adapter 6) Order no. 1400-9740
Isolated serial interface adapter 5), 6) Order no. 1400-7700

USB/RS-232 adapter Order no. 8812-2001

USB/RS-485 adapter R3 Order no. 1402-1300
USB converter 3 Order no. 1400-9377
Memory module Order no. 1400-9379
Mini module 2) Order no. 1400-7436

FSK modem (HART®) Order no. 8812-01xx
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Electropneumatic positioners 
(4–20 mA)

TROVIS 3730-1 •
Type 3730-2 • • •
TROVIS 3730-3 • •
Type 3730-3 • • • •
Type/TROVIS SAFE 3730-6 • • • •
Type/TROVIS SAFE 3731-3 • • • •
TROVIS/TROVIS SAFE 3793 • •

Electropneumatic positioners 
(with bus communication)

Type 3730-4 • • •
Type 3730-5 • • •
Type 3731-5 • • •

Electronic limit switches
Type 3738-20 • • •
Type 3738-50 • • •

1) Depending on the computer used, a USB/RS-232 adapter (8812-2001) may possibly also be required.
2) Restricted	use	of	mini	module:	no	transmission	of	data	logging	configuration	and	parameters	in	the	expert	level;	only	

vacation periods applicable for all control circuits
3) Connecting cable not approved for explosion-protected version
4) USB Converter 3 (1400-9377) only with version 1.41 and higher
5) The driver required for Windows® 8 and higher is installed automatically when TROVIS-VIEW 4.42 or higher is 

being installed.
6) Adapter is suitable for the interconnection with explosion-protected devices. However, interconnection is only 

permissible outside the hazardous area.
7) Discontinued
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Connecting cable RJ-12/D-Sub 1)Order no. 1400-7699

Memory pen-64 (1170-3163) Order no. 1400-9753

Modular adapter 1) Order no. 1400-7698
Hardware package (memory pen-
64, modular adapter, conn. cable)

Order no. 1400-9998

Infrared adapter RS-232 1) Order no. 8864-0900

Bracket for infrared adapter Order no. 1400-9769
USB cable (mini-B, USB type A) 5) Order no. 8801-7301

Isolated USB interface adapter 6) Order no. 1400-9740
Isolated serial interface adapter 5), 6) Order no. 1400-7700

USB/RS-232 adapter Order no. 8812-2001

USB/RS-485 adapter R3 Order no. 1402-1300
USB converter 3 Order no. 1400-9377
Memory module Order no. 1400-9379
Mini module 2) Order no. 1400-7436

FSK modem (HART®) Order no. 8812-01xx
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Differential pressure meters

Media 6 (Type 5006) • • • • • 3)

Media 7 (Type 5007-1) •
SAM Connect Gateway 
(Type 5007-2) •

TROVIS 5500 Automation 
System

TROVIS 5573 • • •
TROVIS 5575 • • • 4)

TROVIS 5576 • • • 4)

TROVIS 5578 • • •
TROVIS 5578-E (Ethernet)
TROVIS 5579 • • • 4)

1) Depending on the computer used, a USB/RS-232 adapter (8812-2001) may possibly also be required.
2) Restricted	use	of	mini	module:	no	transmission	of	data	logging	configuration	and	parameters	in	the	expert	level;	only	

vacation periods applicable for all control circuits
3) Connecting cable not approved for explosion-protected version
4) USB Converter 3 (1400-9377) only with version 1.41 and higher
5) The driver required for Windows® 8 and higher is installed automatically when TROVIS-VIEW 4.42 or higher is 

being installed.
6) Adapter is suitable for the interconnection with explosion-protected devices. However, interconnection is only 

permissible outside the hazardous area.
7) Discontinued
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Connecting cable RJ-12/D-Sub 1)Order no. 1400-7699

Memory pen-64 (1170-3163) Order no. 1400-9753

Modular adapter 1) Order no. 1400-7698
Hardware package (memory pen-
64, modular adapter, conn. cable)

Order no. 1400-9998

Infrared adapter RS-232 1) Order no. 8864-0900

Bracket for infrared adapter Order no. 1400-9769
USB cable (mini-B, USB type A) 5) Order no. 8801-7301

Isolated USB interface adapter 6) Order no. 1400-9740
Isolated serial interface adapter 5), 6) Order no. 1400-7700

USB/RS-232 adapter Order no. 8812-2001

USB/RS-485 adapter R3 Order no. 1402-1300
USB converter 3 Order no. 1400-9377
Memory module Order no. 1400-9379
Mini module 2) Order no. 1400-7436

FSK modem (HART®) Order no. 8812-01xx
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TROVIS 5600 Automation 
System

TROVIS 5610 with interface 
board 2b	(RJ-12	jack	at	front) • • • • •

TROVIS 5610 with interface 
board 1	(USB	B	jack	at	front),	
USB B cable req.

Industrial controllers

TROVIS 6493 • •
TROVIS 6495-2 w/o board • •
TROVIS 6495-2 with RS-232/
USB board • • • • • • •

TROVIS 6495-2 with RS-485/
USB board • • •

1) Depending on the computer used, a USB/RS-232 adapter (8812-2001) may possibly also be required.
2) Restricted	use	of	mini	module:	no	transmission	of	data	logging	configuration	and	parameters	in	the	expert	level;	only	

vacation periods applicable for all control circuits
3) Connecting cable not approved for explosion-protected version
4) USB Converter 3 (1400-9377) only with version 1.41 and higher
5) The driver required for Windows® 8 and higher is installed automatically when TROVIS-VIEW 4.42 or higher is 

being installed.
6) Adapter is suitable for the interconnection with explosion-protected devices. However, interconnection is only 

permissible outside the hazardous area.
7) Discontinued
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Connecting cable RJ-12/D-Sub 1)Order no. 1400-7699

Memory pen-64 (1170-3163) Order no. 1400-9753

Modular adapter 1) Order no. 1400-7698
Hardware package (memory pen-
64, modular adapter, conn. cable)

Order no. 1400-9998

Infrared adapter RS-232 1) Order no. 8864-0900

Bracket for infrared adapter Order no. 1400-9769
USB cable (mini-B, USB type A) 5) Order no. 8801-7301

Isolated USB interface adapter 6) Order no. 1400-9740
Isolated serial interface adapter 5), 6) Order no. 1400-7700

USB/RS-232 adapter Order no. 8812-2001

USB/RS-485 adapter R3 Order no. 1402-1300
USB converter 3 Order no. 1400-9377
Memory module Order no. 1400-9379
Mini module 2) Order no. 1400-7436

FSK modem (HART®) Order no. 8812-01xx
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Electric actuators (with process 
controllers)

Type 3374 • • • • •
Type 3375 7) • • • • •
Type 5824/5825 • • • • •
Type 5827 • • • • •
Type 5857 • • • • •
TROVIS 5724-3 • • • • •
TROVIS 5724-8 (Bluetooth®)
TROVIS 5724-8 (RS-485) •
TROVIS 5725-3 • • • • •
TROVIS 5725-8 (Bluetooth®)
TROVIS 5725-8 (RS-485) •
TROVIS 5757-7 • • • • •

1) Depending on the computer used, a USB/RS-232 adapter (8812-2001) may possibly also be required.
2) Restricted	use	of	mini	module:	no	transmission	of	data	logging	configuration	and	parameters	in	the	expert	level;	only	

vacation periods applicable for all control circuits
3) Connecting cable not approved for explosion-protected version
4) USB Converter 3 (1400-9377) only with version 1.41 and higher
5) The driver required for Windows® 8 and higher is installed automatically when TROVIS-VIEW 4.42 or higher is 

being installed.
6) Adapter is suitable for the interconnection with explosion-protected devices. However, interconnection is only 

permissible outside the hazardous area.
7) Discontinued
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2 Menu bar
The	menu	bar	for	all	device-specific	modules	includes	the	following	menus:	[File],	[Edit],	
[View], [Device], [Options] and [?]. The [Memory pen] menu is only visible for modules that 
allow the use of a memory pen (u Section 1.4).

Menus and menu options can be selected using the mouse or computer keyboard. Press Alt 
together with the key assigned to the menu or menu option to select the menu or menu option 
over the keyboard. The underlined letters of the menus and menu options correspond with 
the	keyboard	keys	that	must	be	pressed	in	conjunction	with	the	Alt	key,	e.g.	Alt+F	for	[File].

2.1 [File] menu

Some of the menu options can also be selected by clicking the corresponding icon on the tool 
bar (u Section 2.3.1) or by using a key combination. The corresponding icons and key com-
binations are shown in the [File] menu.

Note: 

The [Convert Version …] menu option for device modules that cannot be converted is written 
in gray to indicate that this option cannot be selected.

Note
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2.1.1 Creating	a	new	TROVIS-VIEW	file
New	TROVIS-VIEW	files	contain	the	
default values of a device module.

 Î Select [File > New...]. The New 
Module dialog box opens.

 Î Select a language.
The language can be changed at 
any time (u Section 2.6.1).

 Î Select the module for the required 
firmware	version.

 Î Click	[OK]	to	confirm.

Alternatively, open the New Module	dialog	box	by	pressing	Ctrl+N	or	by	click-
ing this icon on the tool bar.

Click this icon to resize the dialog box.

2.1.2 Opening	a	TROVIS-VIEW	file
TROVIS-VIEW	4	files have	the	filename	extension	
".tro_"	plus	a	device	group	identification	code	(for	
example, .tro_64xx for the industrial controllers). 
TROVIS-VIEW	3	files	have	the	filename	extension	
".tro"	without	a	device	group	identification	code.	
These	files	can	also	be	opened	in	TROVIS-VIEW	
4.

 Î Select [File > Open...]. The Open dialog box 
opens.

 Î Select the location from the drop-down list 
where	the	file	is	stored.

 Î Select	the	TROVIS-VIEW	file	you	want.
 Î Click	[Open]	to	open	the	TROVIS-VIEW	file.
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Alternatively, open the Open	dialog	box	by	pressing	Ctrl+O	or	by	clicking	this	
icon on the tool bar.

2.1.3 Saving	a	TROVIS-VIEW	file
TROVIS-VIEW	4	files	are	saved	using	the	file-
name extension ".tro_" 

 Î Select [File > Save].
If	a	TROVIS-VIEW	file	is	to	remain	saved,	save	
the	new	TROVIS-VIEW	file	under	another	name.

 Î Select [File > Save As...]. The Save As dialog 
box opens.

 Î Select the location from the drop-down list 
where	the	file	is	to	be	saved.

 Î Enter	a	file	name.
 Î Click	[Save]	to	save	the	TROVIS-VIEW	file.

Alternatively,	save	the	TROVIS-VIEW	file	by	pressing	Ctrl+S	or	by	clicking	this	
icon on the tool bar.

Alternatively, open the Save As dialog box by clicking this icon on the tool bar.

Note: 

 − TROVIS-VIEW automatically generates a systematically created file name when the box for 
Use	automatic	file	name is checked in [Options > Filename] (u Section 2.6.3).
 − The ‘No complete record from device exists‘ warning indicates that data have not yet been 
uploaded from the device or that not all the data from TROVIS-VIEW have been download-

Note
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ed onto the device. To obtain a complete record including all the changes previously made 
in TROVIS-VIEW, first download the TROVIS-VIEW data to the device and then upload the 
data again.

2.1.4 Printing	a	TROVIS-VIEW	file
The print layout is opti-
mized for a A4 page in 
portrait format.

 Î Select [File > Print...]. 
The Print dialog box 
opens.

 Î Select which data are 
to be printed.
All contents are select-
ed by default: 
R Customer data
R Table of contents
R Comments
R Images and graphs

 Î Select the printer you want to use.
 Î Select which pages you want to print.
 Î Click printer icon to start printing.

Alternatively, open the Print	dialog	box	by	pressing	Ctrl+P	or	by	clicking	this	
icon on the tool bar.

 − The display of the document in the dialog box can be adapted by the icons on the tool bar. 
This does not have any effect on the actual printout layout.
 − The contents of individual folders can be printed separately (u Section 3.5).

Note



18  EB 6661 EN

Menu bar

Zoom in by 25 %

Zoom out by 25 %

Fit to page

Fit to width

Fit to height

Several pages

2.1.5 Converting	a	TROVIS-VIEW	file
If	the	current	version	of	the	TROVIS-VIEW	file	is	not	the	same	as	the	version	of	the	connected	
device,	you	must	convert	the	file	to	match	the	device	version.

The	version	of	the	TROVIS-VIEW	file	appears	on	the	info	bar.	The	version	of	the	actual	device	
is written on its nameplate.

 Î Select [File > Convert ver-
sion…]. The Convert version 
dialog box opens.

 Î Select version.
 Î Click	[OK]	to	confirm.
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Click this icon to resize the dialog box.

2.1.6 Sending	a	TROVIS-VIEW	file	by	e-mail
The	TROVIS-VIEW	files	with	the	filename	extension	“.tro_“	can	be	attached	to	an	e-mail	sent	
by the e-mail program installed on the computer.

 Î Select [File > Send by E-mail...].

Alternatively, open the e-mail program by clicking this icon on the tool bar.

2.1.7 Exporting	a	TROVIS-VIEW	file
The	document	is	exported	as	an	XML	file.

 Î Select [File > Export...] to open the Save As 
dialog box.

 Î Select the location from the drop-down list 
where	the	file	is	to	be	saved.

 Î Enter	a	file	name.
 Î Click [Save] to export the document.



20  EB 6661 EN

Menu bar

2.1.8 Opening	the	most	recently	opened	TROVIS-VIEW	file
The	[Recent	files]	option	allows	you	to	access	the	most	recently	opened	TROVIS-VIEW	files	
without having to search through folders on your hard drive.

 Î Select	the	TROVIS-VIEW	file	by	selecting	[File	>	Recent	files].

2.1.9 Exiting TROVIS-VIEW
 Î Select [File > Exit].

Alternatively, exit TROVIS-VIEW by clicking this icon on the title bar.
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2.2 [Edit]

2.2.1 Cutting out folders and parameters
This	function	can	only	be	performed	in	user-defined	trees	(u Section 3).
You	can	cut	out	folders	and	parameters	and	insert	them	into	a	user-defined	tree	(u Section 
2.2.3).

 Î Select	the	folder	or	parameter	in	the	user-defined	tree.
 Î Select [Edit > Cut].

Alternatively,	cut	out	folders	or	parameters	by	pressing	Ctrl+X	or	by	clicking	this	
icon on the tool bar.

2.2.2 Copying folders and parameters
You	can	copy	folders	and	parameters	and	insert	them	into	a	user-defined	tree	(u Section 
2.2.3).

 Î Select the folder or parameter.
 Î Select [Edit > Copy].

Alternatively,	copy	folders	or	parameters	by	pressing	Ctrl+C	or	by	clicking	this	
icon on the tool bar.

2.2.3 Pasting folders and parameters
This	function	can	only	be	performed	in	user-defined	trees	(u Section 3).
Only folders or parameters that have been cut or copied beforehand can be pasted (u Sec-
tion 2.2.1 and Section 2.2.2).
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 Î Select	the	location	in	the	user-defined	tree	where	the	folder	or	parameter	is	to	be	pasted.
 Î Select [Edit > Paste].

Alternatively,	paste	folders	or	parameters	by	pressing	Ctrl+V	or	by	clicking	this	
icon on the tool bar.

2.2.4 Editing customer data
TROVIS-VIEW allows you to save informa-
tion on the document. The date of creation 
and revision are automatically added and 
cannot be changed.

 Î Select [Edit > Customer data…] to open 
the Customer data dialog box.

 Î Enter the required details. The number of 
characters is not restricted.

 Î Click [OK] to save the details.

Customer data are printed in the TROVIS-VIEW document when the Customer data option is 
checked in the Print dialog box (u Section 2.1.4).

2.2.5 Loading default settings
This command causes all parameters of a document to be overwritten with the default set-
tings	of	the	device	module.	The	command	can	only	be	performed	in	offline	mode	(u Section 
2.4.4).

 Î Select [Edit > Load Default Settings].
 Î Click	[OK]	to	confirm	the	message	“Overwrite	data?”.

Note
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2.3 [View]

2.3.1 Hiding/showing bars and windows
Bars and windows in TROVIS-VIEW can be hidden or shown as required.
All the bars and windows are shown in the default program layout (select [View > Reset 
Layout] u Section 2.3.4). All options are checked (P)) in the [View] menu.

 Î Check or uncheck the status bar and windows in the [View] menu and select [View > 
Toolbars] to show or hide tool bars or windows.

Status bar

The	status	bar	shows	the	device	module	and	the	version	of	the	current	TROVIS-VIEW	file.
If	the	current	version	of	the	TROVIS-VIEW	file	is	not	the	same	as	the	version	of	the	connected	
device,	the	TROVIS-VIEW	file	must	be	converted	to	match	the	device	version	[File	>	Convert	
Version...] u Section 2.1.5.
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Depending on the module, the operating state or condensed state of the device are also indi-
cated on the status bar. Refer to the mounting and operating instructions of the device for 
more details.
Tree
The tree is located on the left-hand side below the 
status bar in the default program layout. It contains 
all the folders and subfolders of a module.

User-defined	tree
The	user-defined	tree	is	located	on	the	left-hand	side	
below the tree window in the default program lay-
out.
The	user-defined	tree	shown	in	a	new	TROVIS-VIEW	
file	depends	on	the	module.	If	a	user-defined	tree	
has been created beforehand for the same module, 
the same tree appears automatically in a new 
TROVIS-VIEW	file.

Trend-Viewer
The Trend-Viewer is located in the bottom of the window in the default program layout. It 
contains a chart of the operating data in online mode (u Section 2.4.4).
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Tool bars
Standard

Meaning of icons (starting on the left):
 − Create	a	new	TROVIS-VIEW	file	(u Section 2.1.1).
 − Open	a	TROVIS-VIEW	file	(u Section 2.1.2).
 − Save	a	TROVIS-VIEW	file	(u Section 2.1.3).
 − Save	a	TROVIS-VIEW	file	with	new	name	(u Section 2.1.3).
 − Cut out folders and parameters (u Section 2.2.1).
 − Copy folders and parameters (u Section 2.2.2).
 − Paste folders and parameters (u Section 2.2.3).
 − Print	a	TROVIS-VIEW	file	(u Section 2.1.4).
 − E-mail	a	TROVIS-VIEW	file	(u Section 2.1.6).
 − Move up one level in the directory (u Section 2.3.2).
 − Change the zoom setting (u Section 2.3.3).
 − Open the About dialog box (u Section 2.7.3).



26  EB 6661 EN

Menu bar

Communication
Offline  

Meaning of icons (starting on the left):
 − Read data from device (u Section 2.4.2).
 − Write data to device (u Section 2.4.3).
 − Start online mode (u Section 2.4.4).

The icon shown on the right appears on the tool bar during online mode of 
the Trend-Viewer (this mode runs separately from the main application).

Communication
Online  

Meaning of icons (starting on the left):
 − Read data from device (u Section 2.4.2).
 − Write data to device (u Section 2.4.3).
 − Start online mode (u Section 2.4.4).

The icon shown on the right appears on the tool bar during online mode of 
the Trend-Viewer (this mode runs separately from the main application).

User level
 (tool bar depending on module)

 − Change the user level (u Section 2.4.1).

Find

Search for a parameter or folder within the document.
 Î Enter search term.
 Î Start search by clicking the magnifying glass icon or with [F3].

Note
Search terms that do not exist in the current document are highlighted in 
red.

Wizard
 (tool bar depending on module)

The wizard guides you through the process of setting up the device step-by-
step.
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2.3.2 Moving up one level in the directory
Moving up one level in the directory is only possible when a subfolder containing parameters 
or other subfolders is shown in the main window.

 Î Select [View > Up One Level].

Alternatively, move up one level in the directory by clicking this icon on the tool 
bar.

2.3.3 Changing the zoom setting
You can zoom in or out of the program window 
within the range between 75 and 200 %.

 Î Select [View > Zoom...] to open the Zoom 
dialog box.

 Î Set zoom or change text sharpness setting.
 Î Click	[OK]	to	confirm.

Alternatively, open the Zoom dialog box by by clicking this icon on the tool 
bar.

 

Decrease the zoom setting when not all the windows or tool bars appear on the screen.

2.3.4 Resetting the layout
This command resets the layout of TROVIS-VIEW to default.

 Î Select [View > Reset Layout].

Note
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2.4 [Device]

2.4.1 Changing the user level
Right of access to certain folders and parameters is assigned in some modules depending on 
the user level.
The	default	user	level	is	displayed	after	opening	a	new	TROVIS-VIEW	file.	Modules	have	dif-
ferent default user levels, for example, Customer, Maintenance technician or Specialist. De-
pending on the module, it may be possible to change to another user level with extended 
read/write access. Refer to the mounting and operating instructions of the device for more 
details.
The user level can only be changed when TROVIS-VIEW and the device are not connected 
(in	offline	mode,	u Section 2.4.4).

 Î Select [Device > User Level] to open the User level di-
alog box.

 Î Select or enter the user level.
 Î To change from the default user level:  
enter password.

 Î Click	[OK]	to	confirm	user	level.
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Alternatively, open the User level dialog box by clicking this icon on the tool 
bar.



30  EB 6661 EN

Menu bar

The user level can be selected directly from the drop-down list on the tool bar.

Changing the password
The default password is "samson". The password can be 
changed.

 Î Enter the currently valid password.
 Î Click option [Change password].
 Î Enter the new password twice:
[Enter new password]
[Confirm	new	password]

 Î Click [Change password] button to save new pass-
word.

The changed password remains saved even after loading the default settings.

2.4.2 Reading data from the device
Reading data from the device causes the complete data record to be uploaded from the de-
vice.

 Î Select [Device > Read].

Alternatively, read data from the device by clicking this icon on the communi-
cation tool bar.

Parameters that have been read from the device are marked in TROVIS-VIEW 
by this symbol.

Note

Note
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Similar topics:
 − Read parameters in a folder and its subfolder from the device (u Section 3.2.
 − Read a single parameter from the device (u Section 4.2.

2.4.3 Writing data to the device
Writing data to the device causes the complete data record to be downloaded to the device.

 Î Select [Device > Write].

Alternatively, write data to the device by clicking this icon on the communica-
tion tool bar.

Similar topics:
 − Write parameters in a folder and its subfolders to the device (u Section 3.3.
 − Write a single parameter to the device (u Section 4.3.

2.4.4 Starting the online mode of the main application
In online mode, communication is established permanently between the device and TRO-
VIS-VIEW.	All	the	configuration	and	operating	data	are	transferred	cyclically	from	the	device	
and displayed in TROVIS-VIEW. Any changes performed in TROVIS-VIEW are directly 
downloaded onto the device.

 

A separate online mode for the Trend-Viewer can be set in [Options > Trend-Viewer]. This al-
lows the online mode of the Trend-Viewer to be started separately from the main application 
(u Section 2.6.5).

Starting the online mode of the main application
 Î Select [Device > Online Mode].

Note
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Alternatively, start the online mode by clicking this icon on the communica-
tion tool bar.

In online mode, this animated icon appears on the communication tool bar.

 

 − If TROVIS-VIEW is unable to find the device, check the server and communication settings 
(u Section 2.6.2).
 − The online mode can only run when the version of the TROVIS-VIEW file matches that of 
the device. A conversion must be performed to start the online mode if this action is 
possible.

 
 
 
 
 
 
 
 

Exiting the online mode of the main application
 Î Select [Device > P Online Mode].

Alternatively, exit the online mode by clicking this icon on the communica-
tion tool bar.

In	offline	mode,	this	icon	is	not	animated	on	the	communication	tool	bar.

Note
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2.4.5 Setting the device address
We recommend to use the serial number of devices that can be connected to TROVIS-VIEW 
over an infrared interface to address them. This is particularly recommendable when several 
devices of the same type are located within range of the infrared adapter.

 Î Select [Device > Addressing ...].
The wizard for device addressing opens.

 Î Follow the instructions.

2.4.6 Perform settings using the wizard
In	some	modules,	a	device	connected	to	TROVIS-VIEW	can	be	configured	step-by-step	using	
the start-up wizard.

 

It is not possible to restore the configuration saved in TROVIS-VIEW or in the device itself that 
was valid before performing the start-up using the start-up wizard.

 Î Select [Device > Start-up wizard]. The Start-up wizard dialog box opens.
 Î Follow the instructions.

NOTICE!
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Alternatively, start the wizard by clicking this icon on the wizard tool bar.

2.5 [Memory pen]
The [Memory pen] menu is only available when a memory pen can be inserted into the 
device.

The memory pen serves as a data carrier and is able to load and store data in its non-vola-
tile memory. The functions of the memory pen described in following are only guaranteed if 
the memory pen-64 (order no. 1400-9753) is used (u Section 1.4).

Copying function
The	memory	pen	can	be	loaded	with	data	configured	in	TROVIS-VIEW	and	the	configuration	
data transferred to one or several devices of the same type and version.
Additionally, the data from the device can be written to the memory pen. This allows the con-
figuration	data	to	be	simply	copied	from	one	device	and	loaded	onto	other	devices	of	the	
same type and version.

Data logging
Device data are logged until the memory pen is full. The data logged in the memory pen can 
be	read	out	in	TROVIS-VIEW	and	saved	to	a	LOG	file	(u Section 2.5.6).

Command mode
A command is downloaded onto the memory pen and transferred onto the device (u Section 
2.5.4).

NOTICE!
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The functions of the memory pen vary depending on the device used (u Section 1.4).

To use the memory pen:
 Î Connect the modular adapter (order no. 1400-7698, u Section 1.4) directly to the COM 
port of a computer or connect it using a USB/RS-232 adapter (order no. 8812-2001) to 
the USB port of the computer.

 Î Set the communication port (u Section 2.5.5).

2.5.1 Reading data from the memory pen
TROVIS-VIEW 4 uploads the complete data record from the memory pen.

Data can only uploaded from memory pens which contain data from the open TROVIS-VIEW 
file. Data cannot be uploaded from memory pens that have been configured as command 
pens.

 Î Select [Memory Pen > Read].

Parameters that have been read from the device are marked in TROVIS-VIEW by 
this symbol.

Note

Note
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2.5.2 Writing data to the memory pen
This command allows data from TROVIS-VIEW to be downloaded onto the memory pen. In 
the Status/action dialog box, the direction in which data are to be transferred between the 
memory pen device is determined.

The status and actions vary depending on the module used. Possible states and actions in-
clude:

Devices without local operation, e.g. Type 3374 and Type 5827 Electric Actuators
 − Device reads memory pen automatically: Data are transferred from the memory pen to 

the device.
 − Device automatically writes to memory pen. Data are transferred from the device to the 

memory pen.

Devices with local operation, e.g TROVIS 6495-2 Industrial Controller and Media 6
 − Reading from and writing to memory pen possible: Data can be transferred from the 

device to the memory pen and from the memory pen to the device over local operation.
 − Only reading from memory pen possible: Data can only be transferred from the memo-

ry pen to the device over local operation. Data transfer from the device to the memory 
pen is blocked.

 − Only writing to memory pen possible: Data can only be transferred to the memory pen 
from the device over local operation. Data transfer from the memory pen to the device is 
blocked.

 Î Select [Memory Pen > Write]. The Status/action dialog box automatically appears.
 Î Select the status/action of the memory pen (�).
 Î Click [Writing...].
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2.5.3 Changing the status
The status determines how the memory pen is to be used when it is inserted into the device.

The selectable status varies depending on the module. Possible states include:

Device modules with command function, e.g. Type 3374 and Type 5827 Electric Actuators
 − Device reads memory pen automatically: Data are transferred from the memory pen to 

the device.
 − Device automatically writes to memory pen. Data are transferred from the device to the 

memory pen.
 − Record data, time-controlled: Operating data are logged in the memory pen according 

to a time schedule.
 − Record data, event-triggered: Operating data are logged in the memory pen triggered 

by an event.

Device modules without command function, e.g. TROVIS 6495-2 Industrial Controller and 
Media 6
 − Reading from and writing to memory pen possible: Data can be transferred from the 

device to the memory pen and from the memory pen to the device over local operation.
 − Only reading from memory pen possible: Data can only be transferred from the memo-

ry pen to the device over local operation. Data transfer from the device to the memory 
pen is blocked.

 − Only writing to memory pen possible: Data can only be transferred to the memory pen 
from the device over local operation. Data transfer from the memory pen to the device is 
blocked.
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 Î Select [Memory Pen > Status...]. The Memory pen action dialog box automatically ap-
pears.

 Î Select status (�).
 Î Click Writing... button.

2.5.4 Setting the command mode
The command mode is only available in 
certain modules.
The command loaded onto the memory 
pen is performed as soon as the memory 
pen is inserted into the device. The com-
mands that can be selected vary depend-
ing on the module.

 Î Select [Memory Pen > Set Command 
Mode]. The Set command mode dia-
log box opens.

 Î Select the command (�) as required.
 Î Click	[Writing...]	to	confirm.

2.5.5 Setting the communication port
Perform the action described once when-
ever	TROVIS-VIEW	cannot	find	the	con-
nected memory pen.

 Î Select [Memory Pen > Communica-
tion Port...]. The Settings dialog box 
appears.

 Î Click [Start] to start automatic detec-
tion. The status changes to 'Device 
found at COM...' if TROVIS-VIEW 
finds	the	memory	pen	connected	to	
the computer.

 Î Click	[OK]	to	confirm	the	communi-
cation settings.



EB 6661 EN  39

Menu bar

2.5.6 Reading recorded data
Data logged on the memory pen by the action 
'Record data, time-controlled' or 'Record data, 
event-triggered'	can	be	saved	in	a	LOG	file	in	
TROVIS-VIEW.

 Î Select [Memory Pen > Read recorded data]. 
After checking the memory pen and the data 
saved on it, TROVIS-VIEW uploads the logged 
data. After reading all the data, the Save As 
dialog box opens.

 Î Select the location from the drop-down list 
where	the	file	is	to	saved.

 Î Enter	the	file	name.
 Î Click [Save] to save data.

2.6 [Options]

2.6.1 Changing the language
The language setting can be changed in the 
offline	mode.

 Î Select [Options > Language] and 
choose the language from the list.
	Î P indicates which language is active.
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2.6.2 Establishing communication with the device
Perform	the	action	described	once	after	opening	a	document	to	allow	TROVIS-VIEW	to	find	
the connected device.

 

Note on Bluetooth communication:
 − For communication over Bluetooth, the connection to the device must be established  using 
the software included with the Bluetooth adapter. If an adapter with legacy pairing (Blue-
tooth version 2.0) is used, you first need to enter the coupling code “1234“. This is not 
needed for a Bluetooth adapter with secure simple pairing (Bluetooth version 2.1 and high-
er).
 − SAMSON devices usually announce themselves to a computer with a name made up from 
the type and serial number (e.g. SAMSON5724-8_....). Devices with older firmware ver-
sions may, however, use the name of the Bluetooth chip manufacturer on announcing them-
selves.

 Î Select [Options > Communication…]. 
The Communication dialog box 
opens.

 Î Click [Server settings...] to open the 
Server settings dialog box.

 Î Select the connection (�):
 − Local connection when the com-

munication server (SCS) and TRO-
VIS-VIEW run on the same com-
puter.

 − TCP/IP connection when the com-
munication server (SCS) and TRO-
VIS-VIEW run on different com-
puters.

 Î Click	[OK]	to	confirm	the	server	set-
tings. The Server settings dialog box 
closes.

Note
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 Î Click [Connection settings...] to open 
the Connection settings dialog box.

 Î Click [Start] to start automatic detec-
tion. The status changes to 'Device 
found at COM...' if TROVIS-VIEW 
finds	the	device	connected	to	the	
computer.

 Î Click	[OK]	to	confirm	the	communica-
tion settings. The Settings dialog box 
closes.

 Î Click	[OK]	to	confirm	the	communica-
tion settings.

2.6.3 Generating	automatic	file	names
If	required,	the	file	name	can	be	automati-
cally generated on saving the latest ver-
sion of a TROVIS-VIEW document. Users 
can determine which details are to be 
used	to	generate	the	file	name.

 Î Select [Options > File Name…]. The 
dialog box as shown here opens.

 Î Check	the	'Use	automatic	file	name'	
box (R).

 Î Select details to be used in the auto-
matically	generated	file	name:
R %T = Type
R %D = Date
R %y = Date (year)
R %m = Date (month)
R %d = Date (day)
R %1P = Serial no.
R %2P = Tag no.

 Î Click	[OK]	to	confirm.
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Note: 

The automatically generated file name can still be changed on saving the TROVIS-VIEW file 
regardless of the settings made here.

2.6.4 Showing message boxes
By checking the ‘Do not show this message again‘ box (R), the last response to the message 
is saved. In the event of a message, it is no longer shown. In order to show the message 
again, the saved (automatic) response must be deleted.

 Î Select [Options > Show Message Boxes].
 Î Select message.
 Î Click [Show message again].
 Î Click [OK].

2.6.5 Configuring	the	Trend-Viewer

Loading a diagram
Trend-Viewer	files	are	saved	using	the	filename	
extension ".log".

 Î Select [Options > Trend-Viewer > Load dia-
gram …]. The Load diagram dialog box 
opens.

 Î Select the directory from the drop-down list 
where	the	file	is	stored.

 Î Select	the	file	you	want	to	open.
 Î Click [Open] to load diagram.

Note
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Loading Trend-Viewer default settings
Loading the default settings of the Trend-Viewer causes all data from the Trend-Viewer to be 
deleted. The Trend-Viewer is shown in the default layout with its default data points.

 Î Select [Options > Trend-Viewer > Load Trend-Viewer default settings].

Selecting online mode
The Trend-Viewer can be run in online mode together with the main application or separate-
ly.
 − Running the online mode together with main application

The refresh rate depends on the total number of data points currently being displayed, 
i.e. including those shown in the main application. The refresh rate may be slower de-
pending on the number of the data points shown in the main window.
Data	recording	finishes	as	soon	as	the	online	mode	of	the	main	application	is	ended.

 Î Select [Options > Trend-Viewer > Online with main application].
 − Running the online mode separately from the main application

The values of the Trend-Viewer are logged according to the selected sampling time (rate). 
The	sampling	time	can	be	adjusted	within	a	range	from	Minimal	(fastest	possible	rate)	to	
300 s.

 Î Select the sampling time from [Options > Trend-Viewer > Trend-Viewer online mode, 
sampling time...].

P indicates active online mode.

This icon appears on the communication tool bar during online mode of the 
Trend-Viewer (this mode runs separately from the main application).

Selecting how the logged values are to be shown in the graph
The values logged in the Trend-Viewer can be shown in the graph exactly as they are record-
ed	or	in	optimized	form.	In	the	optimized	form,	in	addition	to	the	first	and	last	visible	values,	
only the values that have changed since the last recording are shown.

 Î Select menu option:
[Options > Trend-Viewer > Record all points] or
[Options > Trend-Viewer > Optimize values]
P indicates which graph form is active.
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2.7 [?] (Help)

2.7.1 Opening documentation on the device
PDF documents for the device module are saved in TROVIS-VIEW.

 Î Select [? > Documentation] to open documentation on the device.

The most recent documentation is available on the SAMSON website  
(http://www.samsongroup.com).

2.7.2 Opening TROVIS-VIEW documentation
PDF	files	of	these	Operating	Instructions	(EB	6661)	and	the	associated	Data	Sheet	T 6661	
can be viewed in TROVIS-VIEW.

 Î Select [?] (Help).

2.7.3 Opening the About dialog box
If you have any questions about this software, the following details must be submitted:
 − TROVIS-VIEW version
 − Module version
 − Microsoft .NET Runtime version

Details on TROVIS-VIEW 4 are listed in the dialog box.
 Î Select [? > About].

Alternatively, open the About dialog box by clicking this icon on the tool bar.

Note
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3 Tree	and	user-defined	tree
Tree
The	tree	structure	of	TROVIS-VIEW	is	fixed	and	can-
not	be	changed.	All	the	module-specific	parameters	
are arranged in folders and their subfolders.
The contents of the selected folder appear in the 
main window (u	Section	4).	After	opening	a	file,	on-
ly the main folders are shown in the tree. Click  to 
expand the folder and show its subfolders. Click  
to collapse the folder tree. 

A faulty folder or parameter appears in a folder marked by this icon.

The tree structure cannot be changed. Create a user-defined tree with selected contents and a 
different structure in the [User-defined Tree] window.

The [Tree] window is located on the left-hand side below the status bar in the default pro-
gram layout.

User-defined	tree
The	user-defined	tree	can	be	created	as	required	to	
show parameters and folders from the TROVIS-VIEW 
tree.
The	user-defined	tree	shown	in	a	new	TROVIS-VIEW	
file	depends	on	the	module.	If	a	user-defined	tree	has	
been created beforehand for the same module, the 
same tree appears automatically in a new TROVIS-
VIEW	file.
The	[User-defined	Tree]	window	is	located	under-
neath the [Tree] window in the default program lay-
out.

Note
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3.1 Creating	a	user-defined	tree
The	user-defined	tree	is	created	from	the	parameters	of	the	specified	module-specific	tree.	
New folders can be added or existing folders including their contents can be copied from the 
tree	and	inserted	into	the	user-defined	tree.

Adding a folder

 Î Place	the	mouse	cursor	in	the	[User-defined	
Tree] window.

 Î Right-click to open a context-sensitive menu.
 Î Select [Add folder].

A [New folder] is created.

 Î Name the folder.
 Î Click	on	this	icon	to	confirm	the	added	folder.

To add subfolders, select the folder from one level higher up before opening the context-sen-
sitive menu.

Deleting a folder
All the associated subfolders and parameters are deleted on deleting a folder.

 Î Select the folder.
 Î Right-click to open a context-sensitive menu.
 Î Select [Delete folder].

Note



EB 6661 EN  47

Tree	and	user-defined	tree

Copying and pasting folders and parameters
All the associated subfolders 
and parameters are copied 
and pasted on copying and 
pasting a folder.

 Î Select the folder or 
parameter in the TROVIS-
VIEW tree.

 Î Copy the folder or param-
eter by clicking on this 
icon. 

 Î Select the location in the 
user-defined	tree	where	
the folder or parameter is 
to be pasted.
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 Î Paste the folder or param-
eter by clicking on the icon 
shown here. 

You can also drag and drop folders and parameters from the TROVIS-VIEW tree into the us-
er-defined tree.

Renaming a folder
 Î Select	the	folder	in	the	user-defined	tree.
 Î Right-click to open a context-sensitive menu.
 Î Select [Rename folder].

Deleting folders and parameters
 Î Select the folder or parameter in the main application.
 Î Right-click to open a context-sensitive menu.
 Î Select [Delete selection].

Note
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Adding a headline
Headlines arrange the parameters of a folder into individual 
groups.

 Î Right-click on the main window to open a context-sensitive 
menu.

 Î Select [Add headline].

The headline is added above the selected area.

 Î Enter	headline	into	[New	group]	field.
 Î Drag and drop parameters into the newly created group as 
required.

Changing a headline
 Î Select the headline in the main application.
 Î Right-click to open a context-sensitive menu.
 Î Select [Change headline].
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Deleting a headline
 Î Select the headline.
 Î Press delete key to delete headline.

3.2 Uploading data from a folder

When	TROVIS-VIEW	is	running	in	the	offline	mode	(indicated	by	this	icon	
on the communication tool bar), communication can be established by se-
lecting	[Read]	to	specifically	upload	data	from	the	connected	device.	The	
command causes all the parameters of a folder and the associated subfold-
er to be uploaded from the device.

 Î Select the folder.
 Î Right-click to open a context-sensitive menu.
 Î Select [Read].

Parameters that have been read from the device are marked in TROVIS-VIEW 
by this symbol.

Similar topics:
 − Read all parameters from the device (u Section 2.4.2).
 − Read a single parameter from the device (u Section 4.2).

3.3 Downloading data from a folder

When	TROVIS-VIEW	is	running	in	the	offline	mode	(indicated	by	this	icon	
on the communication tool bar), communication can be established by se-
lecting	[Write]	to	specifically	download	data	to	the	connected	device.	The	
command causes all the parameters of a folder and the associated subfold-
er to be downloaded to the device.
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 Î Select the folder.
 Î Right-click to open a context-sensitive menu.
 Î Select [Write].

Similar topics:
 − Write all parameters from TROVIS-VIEW to the device (u Section 2.4.3).
 − Write a single parameter to the device (u Section 4.3).

3.4 Resetting all data to defaults
The [Reset all data to defaults] command causes all write-enabled parameters of a folder and 
the	associated	subfolders	to	be	reset	to	their	default	settings.	The	default	values	are	defined	
for every write-enabled parameter of a device module.

 Î Select the folder.
 Î Right-click to open a context-sensitive menu.
 Î Select [Reset all data to defaults].

Similar topics:
 − Reset all parameters to their default settings (u Section 2.4).
 − Reset a single parameter to its default setting (u Section 4.1).

3.5 Printing data from a folder
The [Print…] command causes all the parameters of a folder and the associated subfolders to 
be printed.

 Î Select the folder.
 Î Right-click to open a context-sensitive menu.
 Î Select [Print…]. The Print dialog box opens.
 Î Perform print settings and start printing (u Section 2.1.4).
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4 Main window
The	parameters	and	subfolders	of	a	folder	selected	in	the	Tree	or	User-defined	Tree	are	
shown in the main window.
The	parameters	are	assigned	to	different	classes	which	are	identified	by	icons:

Parameter can be written to the device: The parameter can be edited and 
written to the device.

Device parameter cannot be edited: The parameter is read from the device.

Parameter can be executed in the device

Device parameter that can be edited but not written to the device

Device parameters that cannot be edited are marked “– – –“ until the parameter is uploaded 
from the connected device.

Various icons in the  column indicate the source from which TROVIS-VIEW has received 
the parameter values. If a parameter is assigned an impermissible value, an error message 
appears instead of the source.

User-edited: The value has been changed in TROVIS-VIEW.

From device: The value has been uploaded from the device. A refreshed value 
during online mode is indicated by a green x in the icon.

From	file,	originally	from	device:	The	value	was	originally	uploaded	from	the	de-
vice,	saved	in	a	file	and	has	now	been	reread	into	TROVIS-VIEW	from	the	file.

Note
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From	file,	originally	from	device:	The	value	was	originally	changed	in	TRO-
VIS-VIEW,	saved	in	a	file	and	has	now	been	reread	into	TROVIS-VIEW	from	the	
file.

From	file:	The	value	originates	from	a	file	that	has	been	saved.

From memory pen: The value has been adopted from the memory pen.

Impermissible or invalid value: Error

Value outside range (top)

Value outside range (bottom)

An icon is not assigned to a parameter before it has been edited in TROVIS-VIEW (default 
setting) or data have not yet been uploaded from the device.

Note
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4.1 Editing parameters

Parameters that can be edited are marked by these icons. These parame-
ters can be edited in TROVIS-VIEW.

 Î Select the parameter.
 Î Right-click to open a context-sensitive 
menu.

 Î Select [Edit].
 Î The Change parameters dialog box 
opens.
Alternatively, open the dialog box by 
double-clicking the parameter.

Parameters with selectable values:
 Î Select value from drop-down list.
 Î Click	[OK]	to	confirm	value.

Parameter	with	specified	range:
 Î Enter	the	value	within	the	defined	range	
or	adjust	it	over	the	–	and	+	scale.

 Î Click	[OK]	to	confirm	value.
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Fast setting of default, minimum and maxi-
mum value:

 Î Select the parameter.
 Î Right-click to open a context-sensitive 
menu.

 Î Select option:
Default: Reset the parameter to the indi-
cated default setting.
Min: Resets the parameter to the indicat-
ed minimum value (only for parameters 
with	a	specified	range).
Max: Resets the parameter to the 
indicated maximum value (only for 
parameters	with	a	specified	range).

Options written in gray indicate that the 
value is the same as the optional setting.

4.2 Uploading a single parameter

When	TROVIS-VIEW	is	running	in	the	offline	mode	(indicated	by	this	icon	
on the communication tool bar), communication can be established by se-
lecting	[Read]	to	specifically	upload	data	from	the	connected	device.	The	
command causes a single parameter to be uploaded from the device.

 Î Select the parameter.
 Î Right-click to open a context-sensitive menu.
 Î Select [Read].

Uploaded parameters are marked by this icon (from device).

Similar topics:
 − Read all parameters from the device (u Section 2.4.2).
 − Read parameters in a folder and its subfolder from the device (u Section 3.2).
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4.3 Downloading a single parameter

When	TROVIS-VIEW	is	running	in	the	offline	mode	(indicated	by	this	icon	
on the communication tool bar), communication can be established by se-
lecting	[Write]	to	specifically	download	data	to	the	connected	device.	The	
command causes a single parameter from TROVIS-VIEW to be downloaded 
onto the connected device.

 Î Select the parameter.
 Î Right-click to open a context-sensitive menu.
 Î Select [Write].

Similar topics:
 − Write all parameters from TROVIS-VIEW to the device (u Section 2.4.3).
 − Write parameters in a folder and its subfolder to the device (u Section 3.3).

4.4 Executing parameters

Parameters that can be executed are marked by these icons.

 Î Select the parameter that can be executed.
 Î Right-click to open a context-sensitive 
menu.

 Î Select [Execute]. Communication is auto-
matically established if the online mode is 
not active.
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5 Trend-Viewer

The Trend-Viewer only appears when it has been activated [P] in the [View] menu. See u 
Section 2.3. In the Trend-Viewer, the values of all write-enabled parameters as well as all de-
vice parameters that cannot be edited can be displayed as a graph plotted over time or in a 
values table. Approximately one million (220) values per data point can be logged at a time. 
At a sampling rate of one second, the maximum logging duration is approx. 12 days. After 
this, the 16000 (214) oldest values are automatically deleted to provide more space for new 
values.
Values can only be recorded and displayed when the online mode for TROVIS-VIEW or the 
Trend-Viewer are active.

This icon indicates that the online mode of TROVIS-VIEW is active. Values 
are only recorded when the ‘Online with main application’ option is 
checked in [Options > Trend-Viewer].

This icon indicates that the online mode of the Trend-Viewer is active. Values 
are only recorded when the ‘Trend-Viewer online mode, sampling time...’ 
option is checked in [Options > Trend-Viewer].

The Trend-Viewer settings are configured in [Options > Trend-Viewer]. See u Section 2.6.5.
Note
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5.1 Configuring	the	Trend-Viewer
 Î Double-click	[Neuer	Ordner]	field	to	name	the	Trend-Viewer.
 Î Activate the online mode of the Trend-Viewer, if required.

Online mode of the Trend-Viewer can be activated.

Online mode of the Trend-Viewer is blocked.

The online mode of the Trend-Viewer is activated in [Options > Trend-Viewer]. If the 
Trend-Viewer is to run in its own online mode, the sampling time (rate) for recording data 
must be selected.

Adding or removing a Trend-Viewer

Use this icon to add a Trend-Viewer to a new tab. Click the tab to go to the 
Trend-Viewer. You can add as many Trend-Viewers as you like.

Use this icon to delete a Trend-Viewer.

5.2 Displaying parameters in the Trend-Viewer
Inserting parameters into the Trend-Viewer
The Trend-Viewer shows write-enabled and non-editable device parameters after they have 
previously been inserted into the Trend-Viewer.

 Î Drag and drop parameters from the main window into the list of parameters in the 
Trend-Viewer.
You can add as many parameters as you like into a Trend-Viewer. For a better overview, 
parameters can be distributed among several Trend-Viewers.

Note
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Changing the parameter representation in the graph
 Î Select the parameter from the list [Name].
 Î Right-click to open a context-sensitive menu.
 Î Select [Settings...]. The Settings dialog box appears.
Alternatively, open the dialog box by double-click-
ing the parameter.

 Î Change the properties of the lines and points.
 Î Click	[OK]	to	confirm.

Note:

If the ‘Visible’ box is not checked, the parameter is not 
displayed in the diagram. The parameter still appears in 
the Values Table.

Deleting parameters
 Î Select the parameter from the list [Name].
 Î Right-click to open a context-sensitive menu.
 Î Select [Delete].

5.3 Configuring	the	diagram
The	standard	diagram	settings	cause	the	entire	adjustment	range	on	the	y-axis	(vertical	axis)	
to be visible. The visible range of the x-axis (horizontal axis) is determined by the window 
width of the diagram.
Unlocking the zoom and scroll function for the y-axis (only relevant when the Trend-Viewer 
diagram has more than one y-axis)

This icon indicates that the y-axes of the Trend-Viewer are linked with one an-
other. You cannot zoom and scroll within a single axis. Click the icon to unlink 
the y-axes.

This icon indicates that the y-axes are unlinked. It allows you to zoom and scroll 
within a single axis. Click the icon to link the y-axes with one another.


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Selecting a single value

This icon is used to select a single value.

 Î Click Select icon.

Shifting display section

This icon shifts the x-axis to the left and right.

 Î Click the icon to shift display section.
 Î Place the mouse cursor on the x-axis until the hand tool appears.
 Î Keep the left mouse key pressed down to shift the x-axis to the left or right.

Zooming in

This icon is used to stretch the axes.

 Î Click the icon to zoom in.
 Î Place the mouse cursor on an axis or in the middle of the diagram until the magnifying 
glass tool appears.

 Î Click to zoom in.
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Zooming out

This icon is used to zoom out the axes.

 Î Click the icon to zoom out.
 Î Place the mouse cursor on an axis or in the middle of the diagram until the magnifying 
glass tool appears.

 Î Click to zoom out.

Sizing all axes to match data contents

This icon allows the entire value range of the parameters to be displayed.

 Î Click the icon to size all axes to match data contents.

Resetting all axes to start values

This icon allows you to show the entire value range of the parameter to be dis-
played on the y-axis. The x-axis starts at 00:00:00 hh:mm:ss and is reset to the 
default scaling which is determined by the window width of the diagram.

 Î Click the icon for resetting all axes to start values.
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5.3.1 Deleting a diagram
The [Delete diagram] command causes the current Trend-Viewer (diagram, values table and 
list of parameters) to be deleted.

 Î Place the mouse cursor on the Trend-Viewer.
 Î Right-click to open a context-sensitive menu.
 Î Select [Delete diagram].

Alternatively, exit the Trend-Viewer by clicking this icon on the tab.

5.3.2 Loading a diagram
Trend-Viewer	files	are	saved	using	the	filename	
extension ".log".

 Î Place the mouse cursor on the Trend-Viewer.
 Î Right-click to open a context-sensitive menu.
 Î Select [Load diagram...]. The Load diagram 
dialog box opens.

 Î Select the directory from the drop-down list 
where	the	file	is	stored.

 Î Select	the	file	you	want	to	open.
 Î Click [Open] to load diagram.
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5.3.3 Saving a diagram
Trend-Viewer	files	are	saved	using	the	filename	
extension ".log".

 Î Place the mouse cursor on the Trend-Viewer.
 Î Right-click to open a context-sensitive menu.
 Î Select [Save diagram...]. The Save As dialog 
box opens.

 Î Select the location from the drop-down list 
where	the	file	is	to	be	saved.

 Î Enter	the	file	name.
 Î Click [Save] to save diagram.

5.3.4 Printing a diagram
 Î Place the mouse cursor on the Trend-Viewer.
 Î Right-click to open a context-sensitive menu.
 Î Select [Print diagram...]. The Print dialog box opens.
 Î Perform print settings and start printing (u Section 2.1.4).
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5.4 Changing to values table

The values table contains all the measured data together with a time stamp of the parameters 
used in the Trend-Viewer.

 Î Select [Values Table] tab.

This icon is used to update the data of the values table.

The time stamp is based on the starting time when the online mode of the Trend-Viewer start-
ed. This starting time is indicated in the Trend-Viewer diagram by ‘t0‘.

Note
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5.5 Exporting data

This icon is used to export the data of the values table.

 Î Select	which	file	format	is	to	be	used	(¤).
 Î Select which decimal separator is to be used (¤).
 Î Select which x-values column is to be used (¤).
 Î Select which time format for the x-axis is to be used (¤)
 Î Click [Export...] to start data export. The Export dialog box opens.
 Î Select	the	location	from	the	drop-down	list	where	the	file	is	to	be	saved.
 Î Click [Save] to save data.
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6 General layout adaptations

6.1 Resizing a window

This icon allows you to change the window size in the horizontal direction.

 Î Place the mouse cursor on the left or right edge of a window until the mouse cursor 
changes to a horizontal two-headed arrow.

 Î Click and hold the left mouse button down to resize the window‘s width.

This icon allows you to change the window size in the vertical direction.

 Î Place the mouse cursor on the top or bottom edge of a window until the mouse cursor 
changes to a vertical two-headed arrow.

 Î Click and hold the left mouse button down to resize the window‘s length.

6.2 Undocking and maximizing a window
The	Tree,	User-defined	Tree	and	Trend-Viewer	windows	can	be	
undocked to show them separately from the program layout. This 
action causes the corresponding window to be undocked, allow-
ing its size and position to be changed as required. Maximizing 
the	window	size	causes	the	window	size	to	be	resized	to	fill	the	
entire screen.

 Î Select [q >  Maximize] or [q > P Dock] in the top window 
bar or from the context-sensitive menu (after right-clicking on 
the window bar).

Window docking
An undocked window can be redocked in another position on the program layout. Position 
the window with the mouse anywhere on the program layout.
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This icon shows all possible docking positions.

Select [View > Reset Layout] to reset how the window looks to the default program layout 
(u Section 2.3.4).

6.3 Closing windows
Click [q > Close] to close a window.

Alternatively, the window can be closed by clicking this icon on the window ti-
tle bar.

Opening windows
Open	a	closed	window	by	selecting	[View	>	Tree]	or	[View	>	User-defined	Tree]	u Section 
2.3.4.

6.4 Hiding windows automatically
A hidden window is only shown as a tab at the window‘s original position in the program 
layout. Place the mouse cursor over the tab to open the window. Remove the mouse cursor to 
close the window again.

This icon, located on the top window bar, allows you to hide a window.

This icon allows you to show a window permanently in the program layout.

Note
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Select [View > Reset Layout] to reset how the window looks to the default program layout 
(u Section 2.3.4).

Note



Key combinations for menus
Alt+D	 Open	the	Device	menu
Alt+E	 Open	the	Edit	menu
Alt+F	 Open	the	File	menu
Alt+O	 Open	the	Options	menu
Alt+V	 Open	the	View	menu
Alt+?	 Open	the	?	(Help)	menu

Key	combinations	for	TROVIS-VIEW	files
Ctrl+N	 Open	new	TROVIS-VIEW	file
Ctrl+O	 Open	saved	TROVIS-VIEW	file
Ctrl+P	 Print	TROVIS-VIEW	file
Ctrl+S	 Save	TROVIS-VIEW	file

Key	combinations	for	user-defined	tree
Ctrl+C	 Copy	folder/parameter	for	a	user-defined	tree
Ctrl+V	 Insert	folder/parameter	into	a	user-defined	tree
Ctrl+X	 Cut	out	folder/parameter	from	a	user-defined	tree
F2 Rename folder or headline
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